Degraded Performance from Apple Servers
Incident Report for iFreeiCloud
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 15:18 UTC
Monitoring
We are seeing simultaneous fixes across all Apple servers. All services are operational, and we are monitoring them closely for the next hour.
Posted Oct 08, 2024 - 14:18 UTC
Update
Services updated to Partial Outage due to elevated errors from Apple servers.
Posted Oct 08, 2024 - 13:17 UTC
Identified
Apple servers have been experiencing issues for the last 15 minutes. Services are running slower due to timeouts and necessary retries.
Posted Oct 08, 2024 - 13:02 UTC
This incident affected: Apple Checks (iFreeCheck, Carrier Check, SIM-Lock Status, FMiP Status, Warranty Check, Identifier Conversion, Model Specifications, MDM Status).