Apple Outage
Incident Report for iFreeiCloud
Resolved
We're in the clear for now, so have marked this incident resolved. We apologize for any disruption caused. On a related note, the Apple event is scheduled for next Wednesday, when the next generation iPhone is expected to launch.
Posted Sep 02, 2022 - 19:35 UTC
Monitoring
All services have been restored just now, but we will continue to monitor in case of further disruption. This behavior is typical in the week leading up to an Apple event (September 7th).
Posted Sep 02, 2022 - 19:00 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 02, 2022 - 18:52 UTC
Identified
An Apple outage has been identified and we are waiting for a prompt resolution from their end.
Posted Sep 02, 2022 - 18:44 UTC
This incident affected: Apple Checks (iFreeCheck Pro, Carrier Check, SIM-Lock Status, Identifier Conversion, Model Specifications).