Carrier Check Maintenance

Incident Report for iFreeiCloud

Update

Service continues to run smoothly with no data errors, despite ongoing disruption on Apple's end. Works are underway to ensure service reliability in the event of long-term or future disruption.
Posted Nov 20, 2025 - 01:46 UTC

Monitoring

We have implemented a new solution to guarantee data accuracy. We are continuing to investigate the discrepancies, which we believe are temporary from Apple's end, likely due to an upcoming product event.
Posted Nov 19, 2025 - 20:16 UTC

Identified

We are implementing a fix to handle these discrepancies.
Posted Nov 19, 2025 - 19:39 UTC

Investigating

We are investigating discrepancies from Apple servers that are causing some carrier checks to fail.
Posted Nov 19, 2025 - 19:28 UTC
This incident affects: Apple Checks (iFreeCheck, Carrier Check, SIM-Lock Status).