Apple Outages
Incident Report for iFreeiCloud
Resolved
Everything is now running smoothly, so we can consider this incident resolved. We apologize for any inconvenience this Apple outage may have caused.
Posted Mar 21, 2022 - 17:51 UTC
Monitoring
Apple systems are returning to operation and all our services have stabilized. We are actively monitoring our services and Apple systems to confirm this has been resolved.
Posted Mar 21, 2022 - 17:29 UTC
Identified
There are currently outages with all Apple systems that we use. We are monitoring these systems for changes or updates from Apple. We apologize for any disruption.
Posted Mar 21, 2022 - 16:50 UTC
This incident affected: Apple Checks (iFreeCheck Pro, Carrier Check, SIM-Lock Status, FMiP Status, Warranty Check, Identifier Conversion, Model Specifications).