Apple updates in progress
Incident Report for iFreeiCloud
Resolved
This incident has been resolved.
Posted May 26, 2022 - 22:35 UTC
Monitoring
Normal operation seems to be restored, although we are continuing to monitor the affected system for possible further activity.
Posted May 26, 2022 - 21:34 UTC
Identified
There appears to be ongoing updates being performed on Apple's system. We are currently able to keep all our services functional, although customers may experience slightly longer processing times throughout. We are monitoring the affected system and will follow up when there's an update.
Posted May 26, 2022 - 21:25 UTC
This incident affected: Apple Checks (iFreeCheck Pro, Carrier Check, SIM-Lock Status, Identifier Conversion, Model Specifications).