MDM Degraded Performance
Incident Report for iFreeiCloud
Resolved
There were no stability concerns in the past 24 hours, so we're marking this resolved.
Posted Jul 17, 2024 - 10:35 UTC
Monitoring
We are no longer seeing any unexpected errors and have additionally implemented a load-balancing solution to improve stability. Performance will continue to be monitored throughout the day.
Posted Jul 16, 2024 - 11:16 UTC
Identified
Due to the recent MDM outage, there is understandably an overwhelming backlog from our clients, and we are seeing elevated errors following the spike in volume. Please bear with us as we get things running smoothly once again.
Posted Jul 16, 2024 - 09:39 UTC
This incident affected: Apple Checks (MDM Status).