FMiP/iCloud Outage
Incident Report for iFreeiCloud
Resolved
This incident has been resolved.
Posted May 23, 2022 - 00:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2022 - 00:30 UTC
Identified
There appears to be an outage with Apple's FMiP database. No FMiP data is available at this time.
Posted May 23, 2022 - 00:18 UTC
This incident affected: Apple Checks (iFreeCheck Pro, FMiP Status).