Apple Services Partially Unavailable
Incident Report for iFreeiCloud
Resolved
All affected services are now operational. We apologize for any inconvenience.
Posted Sep 09, 2022 - 18:04 UTC
Identified
We have adapted our system to recent Apple server-side changes (to prepare for the iPhone 14 launch), but services remain unstable due to limited access to Apple servers. We are offering a special range of (emergency) services to process orders until normal operation is restored; selected API clients have been internally rerouted through our temporary solutions, to avoid disruption.
Posted Sep 08, 2022 - 21:32 UTC
Investigating
We are currently investigating this issue.
Posted Sep 08, 2022 - 19:07 UTC
This incident affected: Apple Checks (iFreeCheck Pro, Carrier Check, SIM-Lock Status, Identifier Conversion, Model Specifications).