FMI Outage

Incident Report for iFreeiCloud

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 12:17 UTC

Monitoring

FMI data is restored, and we are monitoring for further disruption.
Posted Sep 15, 2025 - 11:39 UTC

Identified

FMI data is currently unavailable due to Apple server maintenance. It should be back shortly.
Posted Sep 15, 2025 - 11:27 UTC
This incident affected: Apple Checks (FMiP Status).