iCloud (FMiP) Server Outage
Incident Report for iFreeiCloud
Resolved
This incident has been resolved.
Posted Oct 05, 2021 - 21:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 05, 2021 - 21:13 UTC
Identified
It appears that there's a partial server outage with iCloud, disrupting the availability of FMiP data.
Posted Oct 05, 2021 - 20:29 UTC
This incident affected: Apple Checks (iFreeCheck Pro, FMiP Status).