Apple Outage

Incident Report for iFreeiCloud

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 16:24 UTC

Monitoring

All systems are now back to normal, but we continue to monitor for any potential secondary outages.
Posted Jul 17, 2025 - 13:51 UTC

Identified

We have identified signs of a product launch, which have now caused most Apple systems to hang or intermittently fail. Checks may take longer than normal and may intermittently fail during this period.
Posted Jul 17, 2025 - 13:40 UTC
This incident affected: Apple Checks (iFreeCheck, Carrier Check, SIM-Lock Status, Identifier Conversion, Model Specifications, MDM Status).